网络热词 > EIGRP

EIGRP

EIGRP:Enhanced Interior Gateway Routing Protocol 即 增强内部网关路由线路协议。也翻译为 加强型内部网关路由协议。 EIGRP是Cisco公司的私有协议(2013年已经公有化)。 EIGRP结合了链路状态和距离矢量路由选择协议的Cisco专用协议,采用弥散修正算法(DUAL)来实现快速收敛,可以不发送定期的路由更新信息以减少带宽的占用,支持Appletalk、IP、Novell和NetWare等多种网络层协议。

是Cisco的私有路由协议,它综合了距离矢量和链路状态2者的优点,它的特点包括:

1.Protocol-Dependent Module(PDM)

2.可靠传输协议(Reliable Transport Protocol,RTP)

3.邻居的发现/恢复

4.扩散更新算法(Diffusing Update Algorithm,DUAL)

RTP负责EIGRP packet(下面有讲)的按顺序(可靠)的发送和接收,这个可靠的保障是通过Cisco私有的一个算法,reliable multicast实现的,使用组播地址224.0.0.10,每个邻居接收到这个可靠的组播包的时候就会以一个unicast(单播)作为确认按顺序的发送是通过packet里的2个序列号实现的,每个packet都包含发送方分配的1个序列号,发送方每发送1个packet,这个序列号就递增1.另外,发送方也会把最近从目标路由器接收到的packet的序列号放在这个要发送的packet里,在某些情况下,RTP也可以使用无需确认的不可靠的发送,并且使用这种不可靠发送的packet中不包含序列号.EIGRP第一次传输都采用组播形式,重传输都采用单播。

EIGRP选择一条主路由(最佳路由)和一条备份路由放在topology table(EIGRP到目的地支持最多6条链路).它支持几种路由类型:内部,外部(非EIGRP)和汇总路由.EIGRP使用混合度.

i.EIGRP Metric的5个标准

1.带宽

10的7次方除以源和目标之间最低的带宽乘以256(10的7次方除与最小带宽,然后加上延迟之和除与10,最后乘于256)

2.延迟(delay)

接口的累积延迟乘以256,单位是10微秒

3.可靠性(reliability)

根据keepalive而定的源和目的之间最不可靠的可靠度的值

4.负载(loading)

根据包速率和接口配置带宽而定的源和目的之间最不差的负载的值

5.最大传输单元(MTU)

路径中最小的MTU.MTU包含在EIGRP的路由更新里,但是一般不参与EIGRP度的运算

ii. EIGRP Metric的计算

一般情况下,K5=0;EIGRP度量值的计算公式为:256*{K1(10^7/带宽)+K2(10^7/带宽)/(256-负载)+K3(延迟)} 

由于默认情况下,K1和K3是1,其他的K值都是0.

所以通常情况下,度量值=256×(10^7/最小带宽+累积延时)

如果修改K值,使K5不等于0,则 Metric 计算式变成:256*[K1(10^7/带宽)+K2(10^7/带宽)/(256-负载)+K3(延迟)]*[K5 / (可靠性+K4)]

计算出的Metric值不是整数时自动取整,比如计算结果为8501.39 ,显示值将为8501。

通过配置权重(K值),可以修改EIGRP度量值计算方式。可以再EIGRP配置模式使用命令:Metric weight Tos K1 K2 K3 K4 K5 来修改K值,Tos 只有一个有效值0,否则将被忽略。

EIGRP 要求两台路由器的K值必须相同才能成为邻居。另外,K2,K4,,K5最好不要设置,因为这些参数设置为非零之后,会导致计算度量值时会考虑借口的负载和可靠性,而负载和可靠性会随时间变化,这将导致EIGRP重新泛洪拓扑数据,还可能导致路由器不断地选择不同的路由,由此导致网络不稳定。

EIGRP使用多种类型的packet,这些packet通过IP头部信息里的协议号88来标识:

1. Hello packet

用来发现和恢复邻居,通过组播的方式发送,使用不可靠的发送.

2. ACK(acknowledgement) packet

不包含数据(data)的Hello包,使用unicast的方式,不可靠的发送.

3. Update packet

传播路由更新信息,不定期的,通过可靠的方式发送(比如网络链路发生变化).当只有一台路由器需要路由更新时,update通过unicast的方式发送;当有多个路由器需要路由更新的时候,通过组播的方式发送.

4. Query(查询)& Reply(应答)

Query(查询) & Reply(应答)packet是DUAL finite state machine用来管理扩散计算用的,查询包可以是组播或unicast;应答包是通过unicast的方式发送,并且方式都是可靠的.

5. Request(请求) packet

最初是打算提供给路由服务器(server)使用的,但是从来没实现过.

EIGRP的Update包是非周期性发送的,

1.Hello包在一般的网络中(比如点到点,point-to-point)是每5组播1次(要随机减去1个很小的时间防止同步);

2.在多点(multipoint)X.25,帧中继(Frame Relay,FR)和ATM接口(比如ATM SVC)和ISDN PRI接口上,Hello包的发送间隔是60

秒.

在所有的情况中,Hello包是不需要确认的.可以在接口配置模式下修改该接口的Hello包默认的发送间隔,命令为

ip hello-interval eigrp

当一个路由器收到从邻居发来的Hello包的时候,这个Hello包包含了一个holdown time,这个holdown time告诉这个路由器等待后续Hello包的最大时间.如果在超出这个holdown time之前没有收到后续Hello包,那么这个邻居就会被宣告为不可达,并通知DUAL这个邻居已丢失.默认hold time是3倍于Hello包发送间隔的, 更高链路-- 默认Hello间隔和保持时间是5s和15s T1或低于T1链路-- 分别是60s和180s可以在接口配置模式下修改这个默认的holdown time,命令为

ip hold-time eigrp.

EIGRP邻居信息都记录在邻居表(neighbor table)中,使用show ip eigrp neighbors命令查看IP EIGRP的邻居.

如果EIGRP不考虑环路的问题,那么当右图中连接路由3和4的线路断开后会因到不了network a而使路由1-3相互查询怎么去network a而产生环路。因此EIGRP对于环路的防止考虑两方面:

1.水平分割(Split Horizon)

永远不会在同一个接口下通告一条该接口学到的路由信息

2.路由的毒性逆转(Poison reverse)

接收路由信息的接口,再从该接口通告出刚才学到的路由为不可达

触发条件:

当两台路由器进行邻居初始化时,他们会互相以最大的metric值通告回刚才学到的路由信息(路由中毒)

当拓扑发生改变时,会临时关闭水平分割和毒性逆转,重新学习拓扑

发送查询请求时,会引起水平分割,比如当一个路由器查询一条未知网段去向时,他会向每一个邻居发送查询,处于该网段的继承者(successor)会返回查询给该路由器,而该路由器会反馈一个查询结果给其他邻居,不会再次告诉那个继承者要走这个网段应该要经过自己

在一些大型网络中,往往存在不同的自治区域需要互联的情况。比如在右图的情况下,AS号为1000的要与AS号为2000的两个EIGRP相互通信,只需要在中间路由器配置重分发,注意配置重分发也要避免路由环路。

示例:

Router One

router eigrp 2000 network 172.16.1.0 0.0.0.255

Router Two

router eigrp 2000 redistribute eigrp 1000 route-map to-eigrp2000

network 172.16.1.0 0.0.0.255--在AS=2000内定义邻居AS=1000去AS=2000的网段

!

router eigrp 1000

redistribute eigrp 2000 route-map to-eigrp1000--在AS=1000内定义邻居AS=2000去AS=1000的网段

network 10.1.0.0 0.0.255.255

route-map to-eigrp1000 deny 10

match tag 1000

!

route-map to-eigrp1000 permit 20

set tag 2000

!

route-map to-eigrp2000 deny 10

match tag 2000

!

route-map to-eigrp2000 permit 20

set tag 1000

--当AS=1000的网段被标上(tag)1000的标记,当AS=2000重分发进AS=1000时,被标上1000的路由信息将被拒绝,以防产生环路;反之在AS=2000上亦然。

Router Three

router eigrp 1000network 10.1.0.0 0.0.255.255

现在路由1和3之间就能互访了。

1.弥散更新算法简介

(弥散更新算法可以保证路由100%无环路loopfree)为了能够让DUAL正确的操作,低层协议必须满足以下几个条件:

1. 一个节点要在有限的时间里检测到新邻居的存在或和一个邻居的连接的丢失

2. 在链路上传输的所有信息必须在有限的时间里按正确的顺序收到

3. 所有的消息,包括链路cost的更改,链路故障,和新邻居的发现,都应该是在有限时间里,一个一个的依次处理Cisco的EIGRP使用邻居的发现/恢复和RTP来确保上述前提条件

2.adjacency(邻接)

在刚启动的时候,路由器使用Hello包来发现邻居并标识自己用于邻居的识别.当邻居被发现以后,EIGRP会在它们之间形成一种邻接关系.邻接是指在这2个邻居之间形成一条交换路由信息的虚链路(virtual link).当邻接关系形成以后,它们之间就可以相互发送路由update,这些update包括路由器它所知道的所有的链路及其metric.对于每个路由,路由器都会基于它邻居宣告的距离(distance)和到达那个邻居的链路的cost来计算出一个距离

3.Feasible Distance(FD,可行距离)

到达每个目标网络的最小的metric将作为那个目标网络的FD.比如,路由器可能有3条到达网络172.16.5.0的路由,metric分别为380672,12381440和660868,那么380672就成了FD.

4. Feasible Condition(FC,可行条件)

邻居宣告到达目标网络的的距离小于本地路由器到达目标网络的FD AD < FD => FC=ture.

5.Feasible Successor(FS,可行后继路由)

如果一个邻居宣告到达目标网络的距离满足FC,那么这个邻居就成为FS.比如,路由器到达目标网络172.16.5.0的FD为380672,而他邻居所宣告到达目标网络的距离为355072,这个邻居路由器满足FC,它就成为FS;如果邻居路由器宣告到达目标网络的距离为380928,即不满足FC,那么这个邻居路由器就不能成为FS,FS和FC是避免环路的核心技术,FS也是downstream router(下游路由器),因为从FS到达目标网络的距离比本地路由器到达目标网络的FD要小,

router eigrp 1000network 10.1.0.0 0.0.255.255

现在路由1和3之间就能互访了。

1.弥散更新算法简介

(弥散更新算法可以保证路由100%无环路loopfree)为了能够让DUAL正确的操作,低层协议必须满足以下几个条件:

1. 一个节点要在有限的时间里检测到新邻居的存在或和一个邻居的连接的丢失

2. 在链路上传输的所有信息必须在有限的时间里按正确的顺序收到

3. 所有的消息,包括链路cost的更改,链路故障,和新邻居的发现,都应该是在有限时间里,一个一个的依次处理Cisco的EIGRP使用邻居的发现/恢复和RTP来确保上述前提条件

2.adjacency(邻接)

在刚启动的时候,路由器使用Hello包来发现邻居并标识自己用于邻居的识别.当邻居被发现以后,EIGRP会在它们之间形成一种邻接关系.邻接是指在这2个邻居之间形成一条交换路由信息的虚链路(virtual link).当邻接关系形成以后,它们之间就可以相互发送路由update,这些update包括路由器它所知道的所有的链路及其metric.对于每个路由,路由器都会基于它邻居宣告的距离(distance)和到达那个邻居的链路的cost来计算出一个距离

3.Feasible Distance(FD,可行距离)

到达每个目标网络的最小的metric将作为那个目标网络的FD.比如,路由器可能有3条到达网络172.16.5.0的路由,metric分别为380672,12381440和660868,那么380672就成了FD.

4. Feasible Condition(FC,可行条件)

邻居宣告到达目标网络的的距离小于本地路由器到达目标网络的FD AD < FD => FC=ture.

5.Feasible Successor(FS,可行后继路由)

如果一个邻居宣告到达目标网络的距离满足FC,那么这个邻居就成为FS.比如,路由器到达目标网络172.16.5.0的FD为380672,而他邻居所宣告到达目标网络的距离为355072,这个邻居路由器满足FC,它就成为FS;如果邻居路由器宣告到达目标网络的距离为380928,即不满足FC,那么这个邻居路由器就不能成为FS,FS和FC是避免环路的核心技术,FS也是downstream router(下游路由器),因为从FS到达目标网络的距离比本地路由器到达目标网络的FD要小,存在一个或多个FS的目标网络被记录在拓扑表中。

6.拓扑表(Topological Table)

拓扑表包括以下内容:

目标网络的FD.

所有的FD.

每一个FS所宣告的到达目标网络的距离.

本地路由器计算出的,经过每个FS到达目标网络的距离,即基于FS所宣告到达目标网络的距离和本地路由器到达那个FS的链路的cost.

发现FS的网络相连的接口.

7.邻居表(Neighbor Table)

每个路由器的RAM中都保存有关于邻居的地址和接口信息的表。

8.后继路由(Successor)

又称成功者(Secessful),是到达远程网络的最佳路由。是EIGRP用于转发业务量的路由,它被存储在路由表中。

(1)EIGRP路由协议主要优点

精确路由计算和多路由支持。EIGRP协议继承了IGRP协议的最大的优点是矢量路由权。EIGRP协议在路由计算中要对网络带宽、网络时延、信道占用率和信道可信度等因素作全面的综合考虑,所以EIGRP的路由计算更为准确,更能反映网络的实际情况。同时EIGRP协议支持多路由,使路由器可以按照不同的路径进行负载分担。

较少带宽占用。使用EIGRP协议的对等路由器之间周期性的发送很小的hello报文,以此来保证从前发送报文的有效性。路由的发送使用增量发送方法,即每次只发送发生变化的路由。发送的路由更新报文采用可靠传输,如果没有收到确认信息则重新发送,直至确认。EIGRP还可以对发送的EIGRP报文进行控制,减少EIGRP报文对接口带宽的占用率,从而避免连续大量发送路由报文而影响正常数据业务的事情发生。

快速收敛。路由计算的无环路和路由的收敛速度是路由计算的重要指标。EIGRP协议由于使用了DUAL算法,使得EIGRP协议在路由计算中不可能有环路路由产生,同时路由计算的收敛时间也有很好的保证。因为,DUAL算法使得EIGRP在路由计算时,只会对发生变化的路由进行重新计算;对一条路由,也只有此路由影响的路由器才会介入路由的重新计算。

MD5认证。为确保路由获得的正确性,运行EIGRP协议进程的路由器之间可以配置MD5认证,对不符合认证的报文丢弃不理,从而确保路由获得的安全。

路由聚合。EIGRP协议可以通过配置,对所有的EIGRP路由进行任意掩码长度的路由聚合,从而减少路由信息传输,节省带宽。

实现负载分担。去往同一目的的路由表项,可根据接口的速率、连接质量和可靠性等属性,自动生成路由优先级,报文发送时可根据这些信息自动匹配接口的流量,达到几个接口负载分担的目的。

配置简单。使用EIGRP协议组建网络,路由器配置非常简单,它没有复杂的区域设置,也无需针对不同网络接口类型实施不同的配置方法。使用EIGRP协议只需使用router eigrp命令在路由器上启动EIGRP 路由进程,然后再使用network 命令使能网络范围内的接口即可。

(2)EIGRP路由协议主要缺点

没有区域概念。EIGRP没有区域的概念,而OSPF在大规模网络的情况下,可以通过划分区域来规划和限制网络规模。所以EIGRP适用于网络规模相对较小的网络,这也是矢量-距离路由算法(RIP协议就是使用这种算法)的局限所在。

定时发送HELLO报文。运行EIGRP的路由器之间必须通过定时发送HELLO报文来维持邻居关系,这种邻居关系即使在拨号网络上,也需要定时发送HELLO报文,这样在按需拨号的网络上,无法定位这是有用的业务报文还是EIGRP发送的定时探询报文,从而可能误触发按需拨号网络发起连接,尤其在备份网络上,引起不必要的麻烦。所以,一般运行EIGRP的路由器,在拨号备份端口还需配置Dialer list和Dialer group,以便过滤不必要的报文,或者运行TRIP协议,这样做增加路由器运行的开销。而OSPF可以提供对拨号网络按需拨号的支持,只用一种路由协议就可以满足各种专线或拨号网络应用的需求。

基于分布式的DUAL算法。EIGRP的无环路计算和收敛速度是基于分布式的DUAL算法的,这种算法实际上是将不确定的路由信息散播(向邻居发query报文),得到所有邻居的确认后(reply报文)再收敛的过程,邻居在不确定该路由信息可靠性的情况下又会重复这种散播,因此某些情况下可能会出现该路由信息一直处于活动状态(这种路由被称为活动路由栈),并且,如果在活动路由的这次DUAL计算过程中,出现到该路由的后继(successor)的测量发生变化的情况,就会进入多重计算,这些都会影响DUAL算法的收敛速度。而OSPF算法则没有这种问题,所以从收敛速度上看,虽然整体相近,但在某种特殊情况下,EIGRP还有不理想的情况。

EIGRP是Cisco公司的私有协议。Cisco公司是该协议的发明者和唯一具备该协议解释和修改权的厂商。如果要支持EIGRP协议需向Cisco公司购买相应版权,并且Cisco公司修改该协议没有义务通知任何其他厂家和使用该协议的用户。而OSPF是开放的协议,是IETF组织公布的标准。世界上主要的网络设备厂商都支持该协议,所以它的互操作性和可靠性由于公开而得到保障,并且在众多的厂商支持下,该协议也会不断走向更加完善。

IGRP(Interior Gateway Routing Protocol,内部网关路由选择协议)是Cisco特有的基于距离向量的路由协议,虽然同样应用于规模较小的局域网络,但是,与RIP路由协议有所不同,IGRP使用IP层的端口号9进行报文交换,而RIP则是使用520端口进行报文交换。

IGRP同样是一种动态距离向量路由协议,它由Cisco公司20世界80年代中期设计推出,使用跳数来确定到达一个网络的最佳路径,使用延迟、带宽、可靠性和负载来确定最优路由。默认状态下,IGRP每90秒钟发送一次路由更新广播,在3个更新周期(即270秒)内,如果没有从路由中的第一个路由器接受到更新,则宣布路由器不可访问。在7个周期(即630秒)后,Cisco IOS(网际操作系统)软件会从路由表中清除该路由。

EIGRP结合了链路状态和距离矢量型路由选择协议的Cisco专用协议,采用弥散修正算法(DUAL)来实现快速收敛,可以不发送定期的路由更新信息以减少带宽的占用,支持Appletalk、IP、Novell和NetWare等多种网络层协议。自从EIGRP路由协议诞生后,IGRP路由协议便很少再被使用了。

r1(config)#router eigrp 1

r1(config-router)#net 192.168.1.0激活接口,下行等价命令

r1(config-router)#net 192.168.1.1 0.0.0.255

r1(config-router)#passive-interface fastEthernet 0/1 不从F0/1发hello包

neib 192.168.1.2 / lo 0单播

variance <multiplier> 非等价负载均衡

bandwidth <kbps> 带宽

ip bandwidth-parcent AS 占用带宽

key chain <name> MD5验证

key <ID>

key-string <string>

ip authenticatian mode eigrp <AS> md5

ip authentication key-chain eigrp <AS> <name-of-chain>

show命令:

show ip eigrp int / nei / top / tra/

show ip pro

1. EIGRP metric = (IGRP metric) * 256 IGRP metric is 24 bits in length. EIGRP metric is 32 bits in length.

2. K1 :: Bandwidth = (10,000,000 / bandwidth on interface,kbps) * 256 56K 45714176 1.544M 1657856 (10,000,000 / 1544 = 6476) * 256 10M 256000 100M 25600 1G 2560

3. K2 :: Loading

4. K3 :: Delay sum of delays in the path,in tens of microseconds,mutliplied by 256 Delay = [(sum of the DLY,in microseconds) / 10] * 256 这里的DLY是从本地接口发出后,沿途所经所有源接口的DLY,举例:DLY=8000usec DLY=10000usec . . . DLY=20000usec . DLY=5000usec . . . . . . 12.0.0.0/24 . . |---lo0-( R1 )-s0/0------------------s0/0-( R2 )-lo0---| . . . . . . . . . . . . . . BW=1544Kbit BW=1544Kbit . . . . . . . BW=8000000Kbit BW=8000000Kbit . . . . 1.1.1.0/24 2.2.2.0/24 在R1 上 show ip route 得到的指向2.2.2.0/24 的路由的 metric 值为2,297,856 Bandwidth = (10,000,000 / 1544) * 256 = 6476 * 256 = 1,657,856 Delay = [(20000 + 5000)/10] * 256 = 2500 * 256 = 640,000 metric = K1*BW + K3*Delay = 1657856 + 256000 = 2,297,856 在R2 上 show ip route 得到的指向1.1.1.0/24 的路由的 metric 值为2,118,656 Bandwidth = (10,000,000 / 1544) * 256 = 6476 * 256 = 1,657,856 Delay = [(10000 + 8000) / 10] * 256 = 1800 * 256 = 460,800 metric = K1*BW + K3*Delay = 1657856 + 460800 = 2,118,656 - 通过观察上面2个路由的 metric 可以看出,虽然只是2台路由器2个loopback接口之间的路由,并且在链路带宽一致的情况下,得出的 metric 却是不同的。其原因就是EIGRP 在计算 metric 时所取的DLY 值是路由路径中所有链路的源端口的DLY 值,由于一条链路上的2端接口的DLY 值不同,才产生了2个方向上的不同的 metric 结果。事实上 bandwidth 的值并不是链路上的最小带宽,这个在很多书上的讲解都是错误的,在EIGRP 的 metric 计算中,bandwidth 只是一个性能参考值,并不反映真实带宽,它就是本地接口上显示的BW 值,可以通过接口命令 bandwidth 修改。例如: R2(config)#int s0/0R2(config-if)#bandwidth 1000R2(config-if)#do sh ip routeCodes: C - connected,S - static,R - RIP,M - mobile,B - BGP D - EIGRP,EX - EIGRP external,O - OSPF,IA - OSPF inter area N1 - OSPF NSSA external type 1,N2 - OSPF NSSA external type 2 E1 - OSPF external type 1,E2 - OSPF external type 2 i - IS-IS,su - IS-IS summary,L1 - IS-IS level-1,L2 - IS-IS level-2 ia - IS-IS inter area,* - candidate default,U - per-user static route o - ODR,P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/24 is subnetted,1 subnetsD 1.1.1.0 [90/3020800] via 10.1.1.1,00:00:21,Serial0/0 2.0.0.0/24 is subnetted,1 subnetsC 2.2.2.0 is directly connected,Loopback0 12.0.0.0/24 is subnetted,1 subnetsC 12.1.1.0 is directly connected,Serial0/0

可以看到, 1.1.1.0 的 metric 已从2,118,656 变为3,020,800 5. K4 :: Reliability Can be observed at the result of show interface

6. K5 :: MTU

7. K1~K5 ---> B-L-D-R-M ---> BLack DReaM (这是我的一个记忆技巧)

8. Formula with default K values (K1=1,K2=0,K3=1,K4=0,K5=0): metric = K1*BW + ((K2*BW)/(256-load)) + K3*delay = BW + delay

9. If K5 is not equal to 0: metric = metric * [ K5/(reliability + K4) ]

10.K values are carried in EIGRP hello packets.

11.Mismatched K values can cause a neighbor to be reset.

show run | begin router eigrp//查看配置文件中eigrp的配置命令

show ip protocols//查看当前路由器运行的eigrp协议状态

show ip route summary//查看eigrp路由汇总状态

show ip eigrp neighbors//查看eigrp邻居状态

show ip eigrp interface//查看各个运行eigrp的状态

show ip eigrp interface detail//查看各个运行eigrp的详细状态

show ip route eigrp//查看eigrp协议学习到的路由表

show ip eigrp topology//查看eigrp的拓扑表

show ip eigrp topology all-links//查看eigrp完整的拓扑表

show ip eigrp topology 10.1.1.0 255.255.255.0//产看指定的某个网络参数信息

debug eigrp packets//调试eigrp的查讯包

debug eigrp fsm //调试eigrp的dual算法调试信息

1. EIGRP是cisco专用的,而OSPF则是通用的协议。

2. EIGRP是一个距离矢量协议(有些资料说是混合型的),而OSPF是链路状态协议。

3. EIGRP支持自动汇总功能,它可以在A.B.C类网络的边界实现自动汇总,同时也支持手动配置;而OSPF则不可以,汇总必须手动配置

4. EIGRP的汇聚速度要比OSPF快,因为在它的拓扑图中保存了可选后继,直接后继找不到时可以直接通过可选后继转发。

5. EIGRP的多播地址是224.0.0.10,OSPF是224.0.0.5和224.0.0.6。

6. EIGRP的路径度量是复合型的,OSPF则是Cost型的(当然一般的cost还是根据bandwidth来计算的)

7. 尽管EIGRP支持路由汇总功能,但是它没有分级(hierachical)路由的概念,不像OSPF那样对网络进行分级。

8. 在邻居关系的建立上,EIGRP没有OSPF那么复杂的down-init-two way的过程,只要一个路由器看到邻居的hello包,它就与之建立邻接关系。

9. 在汇总功能的实现上,EIGRP可以在任何路由器的任何接口实现,而OSPF则只能在ABR和ASBR上实现,而且它的路由汇总不是基于接口的。

10. EIGRP支持不等路径度量值的负载均衡,而OSPF则只支持相等度量值的负载均衡。

11. EIGRP使用DUAL算法计算最短路径,而且它采用了有限状态机(finite-state machine)来跟踪所有的路由信息包,保证无回路(loop-free)以及后继路由的选择。OSPF采用Dijikstra算法计算最短路径,它不采用有限状态机。

12. EIGRP邻接关系的确立只要两个参数相符合就行:K-value和AS number;而OSPF的邻接关系的建立需要多个参数符合:hello/dead timer,authentication password,area id,stub flag等。

13. 最后就是它们配置以及检查(show command)上的不同了,这方面不同点很多,就要慢慢体会了。如ospf 中的show ip ospf database对应eigrp中的show ip eigrp topology。

All rights reserved Powered by 网络热词 87994.com

copyright ©right 2010-2020。
网络热词内容来自网络,如有侵犯请联系客服。zhit325@126.com